viernes, 25 de enero de 2019

Compilando Aplicacion Android desde Qt 5.9.1

Desde hace 3 años estoy compilando aplicaciones para Android en el IDE QtCreator. Siempre lo he hecho desde GNU/Linux, no he intentado en otros OS porque en otros no me siento tan còmodo y seguro como en el Ubuntu Mate.

A traves de los años, han sugido nuevas versiones de Android. Hace unos meses, varios, lanzaron Android 8.x, luego de un tiempo de su lanzamiento me enterè que las aplicaciones para dicha sistema no debìan ser desarrolladas con APIs inferiores a la versiòn 23. Dicho de otro modo, màs concreto, Android 8.x solo permite correr aplicaciones creadas con las APIs 23 o superior.

Estos cambios obligan a uno a tener que actualizar el SDK de Android, crear nuevos dispositivos virtuales en el AVD Manager etc.

En ese tràmite estoy ahora. Cuando termine esta tarea, voy a publicar otra entrada dejando detallado en què nuevo contexto estoy realizando las compilaciones en este 2019. Espero que todas estas modificaciones perduren un buen tiempo, 2 años por lo menos. Es mucho pedir lo sè.

Debo anotar todo, registrar cada paso o cambio. Si por alguna razòn de fuerza mayor mi OS deja de existir y las copias de seguridad dejan de ser seguras, tengo que montar todo el SDK de Android y de Qt tal cuàl como lo vengo utilizando. Por ejemplo utilizar el NDK r16e, API 23, Qt 5.9.1, anotar todos los detalles.

Luego de acomodar todo vuelvo por estos mares a traer màs informaciòn.















No hay comentarios:

Publicar un comentario

Entrada destacada

Algunos Script Ùtiles GNU/Linux

Còmo crear un alias con funcion y paràmetros alias gs='gitSubir "$1"' function gitSubir() {     git add *;     git co...